Hi. I'm Dan.
I just found out about the range type for the input element, and i like it thus far. But, as you might have guessed, i have an idea for it. Since images speak louder than words, check this out first: http://jqueryui.com/demos/slider/#range.
As you can see, there are two handles on the scale, which let you define the range. So, for example, you could have a list of products, and filter them, so only those within that range would be displayed.
Sure, you could realize that by just having 2 sliders, one for the min, and the other for the max value. Or could you even overlay them with absolute positioning? *makes a note*
Anyway, to me the JQuery thing represents a range slider more precisely than what we have in HTML5 right now. The current solution is basically just a different representation of a numerical input, not that of a range. In fact, you can't difine a range with it, but only choose a value from within a pre-defined range.
Now i'm not saying drop what you got and do the other thing. But wouldn't it make sense to rename what is there to "slider" and call the jquery thing "range" ?
Either that, or extend the current range type so you can have 2 sliders and really redefine the range, rather than the value.
What's your opinion?
edit: Well, after thinking some more, you could probably just put 2 range inputs next to each other, with one starting where the other left off, and there's your range slider. But you still wouldn't be able to select the lower third for example.